WordPress Minimum PHP Tavsiyesini 7.2'ye Çıkardı

Geçen hafta sonunda WordPress, kullanıcıların daha yeni PHP sürümlerini benimsemelerini sağlama yolunda büyük ilerleme kaydetti. ServeHappy API, kabul edilebilir minimum PHP sürümünü 7.2 olarak ayarlayacak şekilde güncellenirken, WordPress indirme sayfası 7.3 veya daha yeni bir sürüm önermektedir.

WordPress Minimum PHP Tavsiyesini 7.2'ye Çıkardı

Geçen hafta sonunda WordPress, kullanıcıların daha yeni PHP sürümlerini benimsemelerini sağlama yolunda büyük ilerleme kaydetti. ServeHappy API, kabul edilebilir minimum PHP sürümünü 7.2 olarak ayarlayacak şekilde güncellenirken, WordPress indirme sayfası 7.3 veya daha yeni bir sürüm önermektedir.

Sergey Biryukov taahhüt Marius Jensen bir açtıktan sonra meta pistte bir bu değişikliği bilet dokuz gün önce bunun için. Daha önce, ServeHappy gösterge paneli widget'ı PHP 5.6 veya daha düşük sürüm kullanıcılarına yükseltme bildirimi gösteriyordu.

“Çekirdek Site Sağlık ekibi ve Barındırma Ekibi ile tartışan sonra, en mantıklı bir sonraki hareketin PHP kullanıcıları <= 7.1 yükseltme uyarı göstermek olduğunu (ayar bu araçları geldi  ACCEPTABLE_PHP etmek  7.2),” Jensen söyledi.

"Rakamlara baktığımızda, ServeHappy [ki] içeren bir WordPress sürümü çalıştıran sitelerin yaklaşık% 25'inin yükseltme bildirimi alacağını görüyoruz."

Bu değişiklik, WordPress sitelerinin çoğunun PHP'nin kabul edilebilir bir sürümünü kullandığı anlamına gelir. Yaklaşık% 47'si eski sürümlerde WordPress kullanıyor. WordPress 5.2+ sürümünde olanlar (Site Health kullanıma sunulduğunda), ServeHappy API'sı tarafından oluşturulan yükseltme bildirimlerini görür.

Bu güncelleştirme, etkin bir şekilde 7.3'e desteklenen PHP'nin en alt dalını ve 7.2'ye güvenlik güncelleştirmeleri alan PHP'nin en alt dalını da engeller.

Site Sağlık ekibi değişikliği geçen Cuma günü planladı, ancak Jensen API çağrısının bir hafta boyunca önbelleğe alındığını belirtti . Bu hafta boyunca kullanıcılar için ortaya çıkmaya başlamalıdır.

Aralık 2018'de PHP 5.6 ve 7.0 Kullanım Ömrü Sonu'na (EOL) ulaştı ve güvenlik güncelleştirmelerini almayı durdurdu. Bu, 2018 sonunda kullanıcıların yaklaşık% 83'ünü PHP'nin desteklenmeyen sürümlerinde bıraktı. Bugün, Site Sağlık projesi tarafından teşvik edilen ilerleme ile% 47'si desteklenmeyen PHP sürümlerinde . Geçen hafta yapılan güncelleştirme, PHP 7.2'nin Kasım 2020'de EOL'ye ulaşmasından önce bu sayıyı önemli ölçüde azaltmaya yardımcı olacaktır.

Site Sağlık ekibinin bir parçası olarak projeyi koordine yardımcı Jenny Wong, açıklanan onlar nasıl başladığını ve tasarım, Polyglots ile ekipler arasında başarıyla çalıştı ve katkıda Barındırma bu güncelleştirme mümkün kılmak için.

Wong, “WordCamp San Francisco'ya gidip öğle yemeğinde Andrew Nacin ve Mark Jaquith ile oturduğumu ve WordPress'in neden bu kadar eski sürümleri desteklediğini ve projenin bu konuda ne yaptığını sorduğumu hatırlıyorum” dedi. “Bana olan çalışmaları anlattılar.

“Sorunları anlattılar, hepsini bana açıklayıp tüm sorularıma cevap verdiler.”

Wong, 2014'teki bu ilk tartışmanın bir parçası olduğu ve yolculukta düzinelerce katkıda bulunanla paylaştığı için minnettar olduğunu söyledi.

“Onlara attığımız her şeyi tercüme eden poliglotlara, geri bildirimde bulunan, tartışan, savaşan, tartışılan ve tartışan herkese, fikir ve yamaları paylaşan herkese, beni dinleyen herkese şikayet ettim, vahşi fikirlerimi aldım ve onları gerçeğe dönüştürdü - Teşekkürler! ” Dedi Wong.

WordPress'in pazardaki büyük payı göz önüne alındığında, PHP'nin yeni sürümlerinin benimsenmesini teşvik etmek web'i daha güvenli hale getirmeye yardımcı olacaktır. ServeHappy API'sine göre, bu güncellemenin 7.2'nin WordPress ile kullanım için kabul edilen en düşük PHP dalı olduğu anlamına geldiğini lütfen unutmayın. Eski sürümlerde çalışan siteler çalışmaya devam edebilir, ancak WordPress, kullanıcıları yeni sürüme geçirmeye zorlamaya devam edecektir.

 

Kaynak:bulut.net.tr