WordPress 5.4 Beta 1 Test ve Geribildirim için Hazır

Sürüm koordinatörü Francesca Marano, 11 Şubat'ta WordPress 5.4 Beta 1'in piyasaya sürüldüğünü duyurdu . Çalışmaların çoğu blok editörüne odaklandı.  5.4 sürüm programına göre takip eden betalar ve sonraki haftalarda sürüm adayları ile birlikte 18 Şubat için ikinci bir beta sürümün planlanması planlanıyor 

WordPress 5.4 Beta 1 Test ve Geribildirim için Hazır

Sürüm koordinatörü Francesca Marano, 11 Şubat'ta WordPress 5.4 Beta 1'in piyasaya sürüldüğünü duyurdu . Çalışmaların çoğu blok editörüne odaklandı. 

5.4 sürüm programına göre takip eden betalar ve sonraki haftalarda sürüm adayları ile birlikte 18 Şubat için ikinci bir beta sürümün planlanması planlanıyor . WordPress 5.4'ün son sürümü 31 Mart'ta yayınlanacak. Geliştirme döngüsünün bu noktasında, WordPress 5.4 bir özellik dondurma durumundadır, bu da yeni geliştirmelerin veya özellik isteklerinin dikkate alınmayacağı anlamına gelir. Döngünün geri kalanında yalnızca hata düzeltmeleri ve satır içi belgeler planlanmaktadır.

Geliştiriciler , eklentilerini ve temalarını test etmek için beta testi el kitabı sayfasını takip etmelidir . Gelecek sürümü denemek isteyen kullanıcılar bunu WordPress Beta Tester eklentisi aracılığıyla yapabilirler .

Editör Değişikliklerini Engelle

WordPress 5.4, blok editörünün arkasındaki geliştirme projesi olan Gutenberg eklentisinin 10 büyük sürümünü içerecektir. En eski güncelleme olan 6.6 sürümü 2 Ekim'de yayınlandı. En son güncelleme olan 7.5 sürümü 12 Şubat'ta yayınlandı. Hala klasik düzenleyiciyi kullanan son kullanıcılar için sürüm 5.4, blok düzenleyicinin kullanmak için yeterince gelişip gelişmediğini görmek için bir fırsattır. Herkes için hazır olmasa da, kullanıcı deneyimi her sürümde daha iyi olmaya devam ediyor. Blok editörü, Gutenberg eklentisindeki yeni özellikleri henüz test etmeyen kullanıcılar için çok daha gelişmiş hissedecek. Blok düzenleyiciye son kullanıcıları tanıtmak için hoş geldiniz kipi vardır, bu da muhtemelen blok düzenleyicisi indiğinde WordPress 5.0'a eklenmiş olmalıdır. Bu güncelleme ayrıca iki yeni blok içerecektir: sosyal bağlantılar bloğu ve düğmeler grubu bloğu. Yeni gezinme bloğu WordPress 5.4'e inmez. Mark Uraine , kararı açıklayan bir yazıda “Gezinti bloğu şu anda kullanılabilir,” dedi . “Ama bunun henüz yararlı olduğunu düşünmüyoruz - en azından yaşamak için sezgisel bir yeri olana kadar değil.” Amaç, kullanıcıların içerik yayınlamak yerine üstbilgi, altbilgi veya kenar çubuğuna ekleme bağlamında kullanılabilir olmalarıdır. Blok sistemini içerik alanının dışına yönlendiren bir güncellemeye inmesi daha anlamlı olacaktır. Artık birkaç blokta gradyan arka planları dahil olmak üzere fazladan metin ve arka plan rengi ayarları var. Kullanıcılar galeriler için görüntü boyutunu ayarlayabilir, öne çıkan bir görüntüyü sürükleyip bırakabilir ve görüntü bloğunun başlık niteliğini değiştirebilir. Çok bloklu seçim, çok sayıda diğer kullanıcı deneyimi ve erişilebilirlik iyileştirmeleri ile birlikte çok geliştirildi.

Önemli Geliştirici Değişiklikleri

Geliştiriciler, 5.4 beta sürümünde hiçbir kırılma değişikliği olmadığından emin olmak için eklentilerini ve temalarını test etmeye başlamalıdır. Çoğu değişiklik blok düzenleyicide olacaktır. Ancak, WordPress'in diğer alanlarında bazı önemli güncellemeler var.

get_calendar() Fonksiyon ve takvim widget olarak kullandığı bu, bir var olan şeyler, kırılma HTML değişikliği . Önceki ve sonraki ay bağlantıları öğenin altına ve yeni bir  öğeye taşındı . Bu, tema yazarları için takvim tasarımlarını bozabilir. İçin apply_shortcodes()takma ad olarak yeni bir işlev eklendi do_shortcode(). Fonksiyonun amacı, do_*bir eylemi apply_*ima eden fonksiyonlar ile bir filtre veya bir değer döndürmesi gereken bir şey anlamına gelen fonksiyonlar arasında ayrım yapmaktı . Bu tamamen anlamsal bir değişikliktir. WordPress'in çekirdek kodunun çoğunu temsil eden işlev adlandırma karmaşasının daha fazla temizlenmesini görmek güzel olurdu. 16 yıllık teknik borçla, bir revizyon kullanabilir. Belki de bu dört yaşındaki biletin basit bir kısa kod işlevi üzerinde kabul edilmesi bir eğilim başlatabilir. Eklentiler gibi temalar da artık minimum sürüm desteğini ayarlayabilir . Bir tema dosyasındaki Requires at leastve Requires PHPbaşlıklarını kullanarak style.csstema yazarları sırasıyla minimum WordPress sürümünü ve PHP sürümünü ayarlayabilir.