WordPress, Eski PHP Kullanan WP Sitelerinin a'i için Plan Öneriyor

WordPress, Eski PHP Kullanan WP Sitelerinin a'i için Plan Öneriyor

WordPress geliştirme gönüllüleri, potansiyel olarak savunmasız PHP sürümlerinin kullanıcılarını yükseltmeye teşvik etmek için bir teklif yayınladı. Endişe verici sayıda WordPress kullanıcısı, artık güvenlik güncellemelerini almayan PHP sürümlerini kullanmaya devam ediyor.

WordPress, Savunmasız Yayıncıların% 61,6'sına Hitap Ediyor

PHP, WordPress'in üzerinde çalıştığı temel kodlama dilidir. En güncel sürüm PHP 7.3.7'dir.

PHP, daha verimli hale getirmek ve güvenlik sorunlarını düzeltmek için sürekli olarak güncellenir. "Kullanım Ömrü Sonu" durumuna (EOL) ulaşan sürümler hariç. PHP 5.6 ve 7.0 sürümleri Aralık 2018'de EOL'ye ulaştı.

PHP sürüm 7.1, Aralık 2019'da EOL'ye ulaşacaktır.

Resmi WordPress istatistiklerine göre , WordPress yayıncılarının% 45,3'ü sitelerini PHP 5.6 ve 7.0 sürümlerinde çalıştırıyor.

WordPress yayıncılarının% 16,3'ü 5,6'dan daha eski sürümleri kullanıyor.

Bu, artık güvenlik güncellemelerini almayan PHP sürümlerini kullanan WordPress yayıncılarının toplam% 61,6'sıdır.
NOT: Bu sayılar% 100'ün üzerinde% 0,1'dir. Geçerli PHP kullanan sitelerin% 38,5'i + PHP'nin kullanımdan kaldırılmış sürümlerini kullanan% 61,6 =% 100,1. Bu numaralar WordPress'ten .

WordPress Yayıncılarının% 61,6'sı Savunmasız

Bu, WordPress kullanıcılarının% 61,6'sının bilgisayar korsanlığı olaylarına karşı savunmasız olabileceği anlamına gelir. WordPress önerisi, bir nag ekranı kullanarak tüm güncel olmayan PHP kullanıcılarını güncel tutmaktır. Bu, tüm WordPress 5.6 ve altı kullanıcılarına ve ayrıca hala 7.0 sürümünü kullananlara ulaşmak anlamına gelir.

Bu önerilen zaman çizelgesidir:

  1. "Minimum PHP sürümünü artırmak için önerdiğimiz yol haritamız:
  2. PHP 5.6 için PHP güncelleme pencere öğesini görüntüleyin. Bu, widget'ı PHP 5.6 veya altını kullanan herkes için tetikler ve gösterge tablolarında WordPress 5.1+, PHP sürümünü yükseltmenizi tavsiye ettiğimiz gerçeği konusunda onları uyarır.
  3. PHP 7.0 ve altı kullanıcıları için PHP güncelleme pencere öğesini görüntüleyin.
  4. 1. ve 2. noktaların destek ve istatistiklerine dayanarak, bir sonraki adımda PHP 7.1 için PHP güncelleme pencere öğesinin mi yoksa gerekli minimum sürümün PHP 7.2'ye doğrudan yükseltilmesi mi olması gerektiği hakkında bir tartışma yapın. "

Nag Ekran Widget için WordPress Önerisi

Resmi WordPress önerisi bir nag ekranının görüntülenmesini gerektirir. Nag ekranı, kullanıcıları PHP'lerini yükseltmeye teşvik eder.

Resmi açıklamada şunlar belirtilmektedir:

"WordPress'te PHP 5.6 kullanıcıları için PHP güncelleme pencere öğesinin görüntülenmesini tetiklememizi önermek isterim.

Yazma sırasında, WordPress istatistikleri şunları göstermektedir:

PHP 5.6% 29.1 kullanım payına sahip
PHP 7.0% 16.2 kullanım payına sahip
PHP 7.1% 13.2 kullanım payına sahip ”

İlk uyarı ekranı 5 Ağustos 2019'da gösterilmeye başlayabilir. Sonraki uyarı ekranları daha sonraki bir tarihte belirlenecektir.

İşte önerilen zaman çizelgesi:

"PHP 5.6 veya daha düşük kullanıcılar için güncelleme önerisini 5 Ağustos'tan itibaren göstermeye başlamanızı öneririz, PHP 7.0 kullanıcılarına uyarı gösterme zaman çizelgesi bir sonraki gönderide duyurulacak ve destek yükü ve benimseme oranı gibi faktörlere dayanacaktır. önceki artış. "

 

KAYNAK: SEJ